By logging into your account, you agree to our Terms of Use and Privacy Policy, and to the use of cookies as described therein.

You are watching: O/d off light flashing meaning


\"*\"

\"*\"

I have a 03 Ford Ranger 4X4 4.0 SOHC.Every other drive when im traveling at or around 55mph my OD OFF light flashes.When it flashes and I slow down or have to come to a stop, the shift from 1st to 2nd gear is rough every other shift point seems smooth.I can turn off the ignition, restart the truck,the light not flash and everything is ok until that random time it reaches the 55mph.Any ideas?
\"*\"

That happened to me at about 80k miles, and my 1st and 2nd gears had got thrown off. Had to get the transmission rebuilt.
mine randomly did this when the truck had 25k miles on it. happened once. wouldnt go into reverse for about 5 seconds. then it never happened again. then out of nowhere my trans let go after i put 35\"s on it. either way. its bad news. lol
MINE JUST DID THAT THE OTHER DAY!!!! After a day of offroading... i have an automatic and it would shift fine from 1st to 2nd.. but wouldnt shift out of 2nd gear it would just revv wayyyy up and would not shift. I figured it was an electrical problem.. took off the fuse panel lid and blew all the **** out from in my fuse panel. Not sure if this is what fixed it, but honestly just before the tow truck came i was liek **** it ill drive it one more time see if it fixed itself, and sure enough it did...not sure if thats what it was but give it a shot?
Id also try undoing the negative terminal on the battery, leaving it for 10 minutes and hooking ti back up again, reboot the computer. May be electrical as i mentioned
the flashing od light is bad news either way. From what Ive heard, when it flashes, the trans detects slippage.
it did that to me after i burried my truck in the mud drive it around for a while and it will burn up the mud and your trans will be back to normal
It seems like it can also do that if you overheat the transmission. Personally I would pull the battery terminal to reset anything, flush the transmission and not worry until it happens again.My mom\"s last husband had a 99 explorer and the o/d off light flashed one day. The next time he started it up it was off and never acted up again.
There is a way to reset the transmission program. When the truck is cold start the truck without touching the gas. When the idle kicks down run the shifter thru each gear and put it back in park. Let it set and idle until it reaches normal operating temp and shift it thru the gears again. The transmission will relearn all of the shift points. It would also be a good idea to do the trans filter and fluid and possibly adjust the bands.
There is a way to reset the transmission program. When the truck is cold start the truck without touching the gas. When the idle kicks down run the shifter thru each gear and put it back in park. Let it set and idle until it reaches normal operating temp and shift it thru the gears again. The transmission will relearn all of the shift points. It would also be a good idea to do the trans filter and fluid and possibly adjust the bands.

See more: Youre So Beautiful So Damn Beautiful Lyrics, Beautiful (Akon)


Have a Ford dealer or transmission shop pull the Diagnostic Trouble Code(s) to help point you to where the trouble is. Otherwise, you are just guessing like everyone else in this thread. The flashing O/D OFF light is the transmission\"s equivalent of the Check Engine Light. This should be done ASAP. It could be a minor electrical problem or something much more serious. Driving an automatic with a problem could be asking for expensive trouble.Don\"t disconnect the battery or otherwise reset the PCM because the code will be lost.
I\"m not so sure that I\"d flush the tranny if it were me. My buddies 99 Exploders tranny was slipping and a local mechanic (us as well) thought it would be best to drain it, clean the filter and refill it. We did that and all of the friction material was apparently in the old fluid, giving it whatever grip it had internally on the parts. It hardly ever moved again. Unless you revved it to about 3 grand. Then it barely even pulled itself on flat ground. Before that it was at least driveable.GB :)
I have the same OD flashing issues with my 2001 3 speed w/overdrive. It\"s been doing this for 1/2 a year. I cleaned the sensors but didn\"t help. I just the other day remembered I drove through standing water (6 inches deep) and realized this is about the same time the OD started flashing so I checked connections for issues and started to clean the speed sensor on the rear end when I noticed a drip of water coming from the connection, as I pulled the connector off I saw a crack in the wiring harness and but continued to remove the connector, I couldn\"t believe how much water was in the connector and harness. the top of the sensor looked dry but I think it may need to be replaced. Any one else have this same issue?

Contact Us -Sitemap -Advertising -Cookie Policy -Privacy Statement -Terms of Service -Do Not Sell My Personal Information -

© 2021 MH Sub I, LLC dba Internet Brands


Contact Us -Sitemap -Advertising -Cookie Policy -Privacy Statement -Terms of Service -Do Not Sell My Personal Information -Top
LinkBack
\"*\"
LinkBack URL
\"*\"
About LinkBacks
Bookmark & Share
\"*\"
Digg this Thread!
\"*\"
Add Thread to del.icio.us
\"*\"
Bookmark in Technorati
\"*\"
Tweet this thread